Angepinnt Interessen-Anfrage: MS-Dos Spiel in Eigenproduktion

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Neu

      dantist schrieb:

      Problem gelöst :smartass setup.exe unter Windows 95 starten - dort erkennt er die Soundtreiber! Dann unter DOS booten und es läuft :Banana
      Das klingt irgendwie danach, als ob unter DOS keine Soundtreiber geladen würden.
      Auch wenn das Problem ja schon gelöst ist, Angaben zur Soundhardware und die Inhalte von config.sys und autoexec.bat unter DOS (!) wären interessant.
      Ich werde mich von keinem einzzzigen Prozzzessor trennen.
      Jedoch lockt es mich beinahe, ihn Dir zu überlassen, nur um zu sehen, wie er Dich in den Wahnsinn treibt :evil:

      Meine Begehren
    • Neu

      ja genau das! Poste mal deine Config und checke die Pfade der Treiber nach
      Chaintech 486SPM// X5 133Mhz // 16MB RAM // Riva128 // GUS2.4 & AWE32// 2GB SD & 4GB WD // 17" CRT
      Tyan S1564 // P1-233MMX // S3 4MB // AWE64 Gold mit Roland SC-55 // 128MB SOD + 4GB HDD
      Der DosReloaded YT Kanal ! :thumbsup:
      :!: Verkaufe: ==Mein Verkaufsthread== <---update 03/2019
      :?: SUCHE Bigbox Games aktualisiert <---update 1/2019
    • Neu

      Bei anderen DOS-Spielen habe ich keine Soundprobleme, würde mich wundern, wenn es an der Config liegt. Aber vielleicht seht ihr ja einen Fehler.

      autoexec.bat

      Quellcode

      1. @echo off
      2. mode con codepage prepare=((850) C:\WINDOWS\COMMAND\ega.cpi)
      3. mode con codepage select=850
      4. path=C:\
      5. keyb gr,,C:\WINDOWS\COMMAND\keyboard.sys
      6. c:\tools\dos\ctm-de.exe
      7. c:\tools\dos\dosed -q -i -l
      8. set dircmd=/O:GN
      9. GOTO %CONFIG%
      10. :WIN
      11. cls
      12. echo Windows 95 wird gestartet...
      13. win
      14. GOTO END
      15. :DOS
      16. GOTO END
      17. :DOSCD
      18. c:\tools\dos\shsucd\shsucdx /D:SHSU001
      19. GOTO END
      20. :END
      Alles anzeigen


      config.sys

      Quellcode

      1. [Menu]
      2. MENUITEM=WIN,Windows 95
      3. MENUITEM=DOS,DOS
      4. MENUITEM=DOSCD,DOS + CD ROM
      5. MENUDEFAULT=WIN,2
      6. [Common]
      7. device=C:\WINDOWS\HIMEM.SYS
      8. device=C:\WINDOWS\EMM386.EXE NOEMS I=B000-B7FF
      9. REM device=C:\WINDOWS\EMM386.EXE RAM AUTO I=B000-B7FF
      10. DOS=HIGH,UMB
      11. device=C:\WINDOWS\COMMAND\display.sys con=(ega,,1)
      12. Country=049,850,C:\WINDOWS\COMMAND\country.sys
      13. [WIN]
      14. [DOS]
      15. [DOSCD]
      16. device=c:\tools\dos\OAKCDROM.SYS /D:SHSU001
      Alles anzeigen
    • Neu

      wo lädt denn der Soundtreiber ? ist es dieses ctm-de ? (nie gehört)

      du musst auf jedenfall die Set blaster drin stehen haben. Einige Spiele schauen nur danach, selbst wenn du keine Soundblaster-Karte hast
      Und ich würde das oakcdrom.sys durch videcdd.sys ersetzen, frisst weniger Speicher ^^
      Chaintech 486SPM// X5 133Mhz // 16MB RAM // Riva128 // GUS2.4 & AWE32// 2GB SD & 4GB WD // 17" CRT
      Tyan S1564 // P1-233MMX // S3 4MB // AWE64 Gold mit Roland SC-55 // 128MB SOD + 4GB HDD
      Der DosReloaded YT Kanal ! :thumbsup:
      :!: Verkaufe: ==Mein Verkaufsthread== <---update 03/2019
      :?: SUCHE Bigbox Games aktualisiert <---update 1/2019
    • Neu

      Wobei wir immer noch nicht wissen, um welchen Soundchip wir uns hier kümmern sollen rolleyes3-maybe-best.gif

      Also hab ich jetzt mal an Hand der Bilder seines Notebooks aus Beitrag 597 gesucht - es ist wohl ein Toshiba Satellite Pro 400 CDT - und das hier gefunden:
      support.dynabook.com/support/s…38306&isFromTOCLink=false
      (wäre einfacher, wenn der Fragende solche Infos bereitstellen würde, gell @dantist rolleyes3-maybe-best.gif, aber Du hast ja schon selbst einen Weg gefunden, von daher: was soll's, aber mir ist gerade langweilig ;) )

      Demnach müßte ein ESS Technologies ESS688 & Yamaha OPL3 (YMF262) verbaut sein.
      Dazu findet man dann bei den Vogonen einen Thread, in dem sich schon andere User über mangelnde DOS-Kompatibilität auslassen:
      vogons.org/viewtopic.php?f=46&t=47585
      und weiter unten ein Zitat von der Toshiba Webseite:
      "Subject: ESS Sound System compatibility with Sound Blaster Pro DOS based
      software/games requiring Sound Blaster or Sound Blaster Pro compatible
      sound cards. The following Toshiba units shipped with the ESS 688 Sound
      System chip which is compatible with Creative Labs Sound Blaster chipset:
      Satellite Pro 400CS/CDT
      Satellite Pro 410CS/CDT
      Portege 610CT
      Tecra 700CT
      During installation and setup, various games may have difficulty detecting
      SoundBlaster Pro or ANY sound card at all.

      Solution: Move Sound I/O Address in TSETUP from 220 (default) to 240
      and IRQ to 10 (default). DMA channel should be set to 1 (default).
      In the autoexec.bat file add the following:
      ...
      set blaster=a240 i10 d1
      set midi=synth:1 map:e"
      (vogons.org/viewtopic.php?f=46&t=47585#p642089)

      Allerdings gibt es wohl einige Spiele, die IRQ 10 nicht mögen (z. B. Wolfenstein 3D). IRQ 5 oder 7 funktionieren dagegen wohl deutlich besser. Viel wichtiger ist es, daß die BLASTER-Variable in der autoexec.bat steht, was der Treiber aber wohl nicht (immer?) selbständig erledigt.
      Ich werde mich von keinem einzzzigen Prozzzessor trennen.
      Jedoch lockt es mich beinahe, ihn Dir zu überlassen, nur um zu sehen, wie er Dich in den Wahnsinn treibt :evil:

      Meine Begehren
    • Neu

      Oh wow, und ich dachte, ich wüsste alles über mein geliebtes Toshiba :) Es geht tatsächlich um den 400CDT, vielen Dank für die Infos.

      Den Port auf 240 zu ändern hat nichts gebracht, aber mit dem SET BLASTER in der autoexec.bat erkennt Mars 3D die Soundkarte auch im DOS-Modus :thumbup:

      Quellcode

      1. set blaster=a220 i10 d1
      Weitere Parameter, die man so findet (D1 H5 P330 T6) sagen mir nichts, scheint aber auch ohne zu gehen.

      Und ja, ctm-de ist Cutemouse - sehr zu empfehlen!


      Jigo schrieb:

      Und ich würde das oakcdrom.sys durch videcdd.sys ersetzen, frisst weniger Speicher ^^
      Kenne ich gar nicht, ist das kompatibel mit SHSUCD?
    • Neu

      dantist schrieb:

      Weitere Parameter, die man so findet (D1 H5 P330 T6) sagen mir nichts, scheint aber auch ohne zu gehen.
      D = low level 8-bit DMA-Kanal
      H = High level 16-bit DMA-Kanal
      P = MIDI-Port für Wavetable/General MIDI
      E = Port des EMU8000 auf AWE32-Karten
      T = Kartentyp:
      - 1=SoundBlaster v1.x (8-bit mono 22khz) or compatible
      - 2=SoundBlaster Pro (8-bit stereo) or SB Pro compatible
      - 3=SoundBlaster v2.x clone (8-bit mono 44khz) or compatible
      - 4=Soundblaster Pro 2
      - 5=Soundblaster Pro MCA
      - 6=SoundBlaster 16 or SB16 compatible

      siehe auch:
      mail.lipsia.de/~enigma/neu/soundconfig.html
      rinkworks.com/apogee/s/6.4.2.shtml

      Wenn sie nicht gebraucht werden, muß man sie auch nicht angeben.
      Ich werde mich von keinem einzzzigen Prozzzessor trennen.
      Jedoch lockt es mich beinahe, ihn Dir zu überlassen, nur um zu sehen, wie er Dich in den Wahnsinn treibt :evil:

      Meine Begehren