Frage zu 2nd Level Cache und Identifikation eines 386er Motherboards

  • Gesundes Neues zusammen,


    ich habe hier dieses funktionsfähige 386er Board zu liegen und versuche zum einen herauszufinden, von welchem Hersteller es ist und zum anderen, ob es sinnvoll oder sogar nötig ist, dieses mit 2nd Level Cache auszustatten.


    Es handelt sich lt. Aufdruck um ein A10001 Rev.C aus dem Jahr 1992 mit einem OPTI 82C283 Chipsatz im quadratischen Baby-AT Format.
    Es hat einen Intel 386 SX 25 MHz Prozessor fest verlötet. Die BIOS-Tonne wurde bereits vor Jahren entfernt, ein externer Batterieanschluss ist aber vorhanden (J3)


    1992 ISA 386 Board A10001 Rev.C (OPTI 82C283).JPG 386 Board A10001 Rev.C (OPTI 82C283) mit Intel 386SX-25_1.JPG


    Sehe ich das richtig, dass momentan gar kein Cache installiert ist?
    Die 128K aus dem POST-Screen bedeuten etwas anderes, oder?


    Bisher hatte ich immer Boards mit Cache Modulen installiert, war das Damals(TM) evtl. üblich, 386er ohne Cache auszuliefern?


    Falls eine Cache Aufrüstung sinnvoll ist: In meinem Fundus befinden sich folgende Sets an Cache-Modulen. Ist da etwas passendes dabei?
    Ich wollte es nicht einfach stecken, nicht das da noch etwas "hoch geht". :atomrofl


    Foto 24.01.17 07 55 57.jpg Foto 24.01.17 07 57 02.jpg Foto 24.01.17 07 56 13.jpg


    Danke für Eure Hilfe!


    Schöne Grüße
    eltrash

  • Bisher hatte ich immer Boards mit Cache Modulen installiert, war das Damals(TM) evtl. üblich, 386er ohne Cache auszuliefern?

    Es war eher unüblich, dass der 80386 Cache überhaupt hatte. ;)


    Was bei dir dort in den Sockel gehört ist kein SRAM, sondern normaler RAM.
    Das ist im wahesten Sinne normaler RAM. Das board kann SIMM und / oder SIPP RAM Aufnehnen (die Käfer).


    Was das CMOS Setup meldet ist kein Cache, sondern seine eigene Kopie aus dem EPROM im RAM, weil
    RAM Zugriffe gegenüber Zugriffe auf den EPROM definitiv schneller sind.

  • Es war eher unüblich, dass der 80386 Cache überhaupt hatte.

    Gut zu wissen, mein DX-40 hat aber schon welchen.

    Das board kann SIMM und / oder SIPP RAM Aufnehnen (die Käfer).

    Das sind SIPP RAM Sockel und gar keine Cache Sockel?
    Daran hab ich nun gar nicht gedacht. :Face

    Was das CMOS Setup meldet ist kein Cache, sondern seine eigene Kopie aus dem EPROM im RAM, weil

    Ok,also zweigt sich das BIOS 128K von installierten RAM als Shadow ab, alles klar.


    Man lernt nie aus. Danke vielmals

  • Gut zu wissen, mein DX-40 hat aber schon welchen.

    Das kann gut sein. Gegen Ende hat man ja auch im 386 Sektor nochmal was kleines zugelegt.
    Mein Octek Jaguar V schein auch 8K Cache zu haben. Aber wirklich zugeben will es das nicht.
    Weder Softwaretechnisch noch was Gedrucktes hab ich diesbezüglich was gefunden.

  • Die späten und schnelleren 386DXer-Systeme (33-40MHz) hatten oft L2-Cache, die langsameren DXer eher selten und die SXer fast nie.

    1992 ISA 386 Board 019K1 (SIS 85C 460 ATQ).jpg


    Könntet Ihr mir bitte bei diesem Board mit einem AMD 386DX-40 nochmal behilflich sein?


    Ich suche auch hier die Shematics, Jumperstellungen und Board-Bezeichnung. ^^


    Es sind gerade 128KB Cache installiert und ich würde diesen gerne auf 256KB ausbauen.
    Kann ich die Baussteine von "Mosel MS62256A-25NC" (siehe erstes Foto im Eingangsthread) dafür verwenden, obwohl diese von einem anderen Hersteller sind als die momentan verbauten :?:


    Und da nur ein gefüllter Sockel und guter Sockel ist, welchen Co-Prozessor könnte ich da einsetzen?



    Danke für die Hilfe .
    Grüße
    eltrash

  • Wahnsinn, ich habs gewusst, dass @tom4dos das Board identifizieren kann, Danke vielmals :super , auch an @kylix für die Bezeichnung.


    Ich nehme an, der Takt des CoPros darf nicht kleiner als 40 MHz sein? Dann kommen ja nicht mehr viele in Frage.
    Unabhängig davon, macht ein CoPro in einem DX eigentlich Sinn?

  • Hallo zusammen,


    da sieht man die schöne PC-Vorstellung von speedsalat Die Nummer 3 - ein schöner 386er und die tollen Benschmarks mit 256kb Cache und sofort ist das 2 Jahre alte Thema wieder aktuell. :whistling:


    Ein Koprozessor ist mittlerweile erfolgreich verbaut und funktioniert einwandfrei.


    IMG_9023.JPG IMG_9029.JPG



    Jetzt möchte ich gerne von 128KB auf 256KB Cache aufrüsten, die DIP28 Sockel sind bereits vorhanden.

    Momentan sind vier 32Kx8 Bit Module und ein 8Kx8 als Tag-Ram verbaut


    1992 ISA 386 Board SOYO SY-019K1 (SIS 85C 460 ATQ).jpg


    Lt. Datenblatt http://www.uncreativelabs.de/th99/m/U-Z/32256.htm

    werden für 256KB Cache weitere vier 32Kx8 Bit Module und als Tag-Ram ebenfalls ein 32Kx8 Bit Modul benöltigt.


    cache.JPG



    Würden die Mosel MS62256A-25NC Chips aus dem ersten Beitrag da passen?

    Die haben zwar 25ns, aber die hätte ich sofort da. ;)


    Danke für Eure Hilfe.

    Grüße

    eltrash

  • Ich würde es also auf jeden Fall mal mit den Chips versuchen. Normalerweise sollten die 25ns Chips schon ausreichend sein. Die Thematik ist zwar etwas komplexer aber HIER war man auch zuversichtlich, dass es mit 25ns Chips läuft (HIER wird noch etwas auf die Timings eingegangen).

  • Hi,


    ich hab' jetzt doch lieber 20ns Chips verbaut. (für 4 EUR+2 Versand von eBay geschossen ;))

    4 von denen hab ich in die freien Plätze gesteckt und +1 weiteren gegen den 8x8 Tag-RAM getauscht.

    3 Jumper lt. Datenblatt auf 256 kB Cache umgesteckt und Testlauf. :tasskaff


    1.jpg


    2.jpg



    3.jpg


    Es hat alles geklappt. :thumbup:

    VGA Bench ist zwar nicht schneller geworden (14,9 Punkte) aber lt. Config 9.33 hab ich etwas mehr Datendurchsatz bei der Zeichenausgabe DOS/BIOS. :super

  • egal, ein 386er mit 128KB Cache ist generell schon was Feines und mit 256KB etwas noch Feineres ;)


    Kann man an den BIOS Einstellungen noch etwas optimieren?

    Die Takte auf der rechten Seite 1T / 2T / 1T ist bereits die schnellste Einstellung.


    Was hat es mit dem markierten Eintrag: "Bus Clock Frequency Select auf sich?

    Einstell Optionen sind: 1/10CLK, 1/8.., 1/6.., 1/5.., 1/4.., 1/3.., 1/2CLK und 7,15MHz

    Original stand es auf "7,15MHz".


    Ich hab eine 40 MHz CPU drin, der ISA Bus läuft ja bekanntlich mit 8 MHz.

    Müsste man doch eigenlich auf 1/5CLK stellen, oder? Damit bootet der PC jedoch nicht mehr.

    Oder hab ich einen Denkfehler ?(


    Sicherheitshalber erstmal auf 1/10CLK eingestellt, damit bootet er ganz normal. Ich merke auch keinen Leistungsverlust.


    5.jpg

  • Möglich, dass damit der externe Clock gemeint ist. Bei einem 386DX40 war das meist ein 80MHz Clock-Generator.


    Willst du nicht mal das BIOS korrigieren? Die "Vedio Cacheable Option" tut ja in den Augen weh :crazy

  • Willst du nicht mal das BIOS korrigieren? Die "Vedio Cacheable Option" tut ja in den Augen weh

    Ist mir zwar aufgefallen, aber stört mich jetzt nicht so. Rechtschreibfehler waren früher ja überall an der Tagesordnung. Vor allem bei den Übersetzungen.


    Mit den 80 MHz wäre eine plausible Theorie, dann würde ja 1/10CLK passen.

    Ich teste aber noch 1/8CLK :D


    EDIT: mit 1/8 startet er auch nicht

  • Ok, wenn ich die RAM Timings etwas entschärfe, startet er auch mit 1/8CLK und VGABench hat gleichmal 15,8 Punkte. :scared


    Lt. meinem BIOS Kompendium (von Data Becker) bedeutet "Bus Clock Frequency Selection" der Teilungsfaktor des ISA Busses im Verhältnis zum Systemtakt.

    Das Buch ist allerdings schon aus den 2000ern, als die meisten PCs schon 33MHz Systemtakt hatten.


    Die Frage ist nun, welches ist bei meinem 386er der Systemtakt? 40MHz CPU oder 80 MHz Oszilator?

Jetzt mitmachen!

Sie haben noch kein Benutzerkonto auf unserer Seite? Registrieren Sie sich kostenlos und nehmen Sie an unserer Community teil!