Windows 98 SE auf einer 64 GB SSD installieren - HILFE!!!

  • Hi,


    bin gerade am Phil-Pentium-4-Projekt. Soweit alles zusammengebaut, Komponenten laufen.


    Komponenten Kurzbeschreibung:


    - Plextor DVD-ROM, IDE (IDE 2, Master)
    - 64 GB SSD, ATA (Transcend SSD370S)
    - ASRock P4i65G mobo
    - 3 GHZ Intel Pentium 4
    - 2 x 512 MB GEiL DDR RAM
    - Etc.


    Meine Probleme:


    Windows lässt sich ohne Probleme installieren, jedoch kann ich es nachher nur im abgesicherten Modus starten.
    OK, bis dahin sind keinerlei Treiber installiert - nur das "Roh" Windows! Der PC will dann einfach nicht mehr starten.
    Habe schon versucht im abgesicherten Modus den chipset-Treiber zu installieren, aber dann folgt nochmals die
    Windows-CD-Abfrage wg. einiger Datein und es wird kein DVD-LW erkannt. Hab auch schon versucht zu tricksen und
    Windows versucht via USB auf die Platte zu kopieren, leider ohne Erfolg. Der chipset-Treiber liess sich unter DOS
    rüberkopieren.


    Vor der Installation hat die Windows-CD die Festplatte formatiert, somit sollte es ja FAT32 sein.


    Kurzum:


    1. Windows funktioniert nur im abgesicherten Modus.
    2. DVD-LW wird nicht erkannt (Windows lässt sich aber installieren)


    HELP!!!

  • Hmmm. Win98 und SSD hört sich zusammen tückisch an. Wie ist die SSD im Bios eingestellt?

    Meine Vintagerechner: XT (NEC V20) #-# Epson XT portable #-# HighScreen 286@16MHz #-# L&P 286-20MHz #-# Cyrix 386DRx²-33/66 #-# ESCOM Black Slim Am386DX@40MHz #-# IndustriePC Am5x86-133 #-# Cyrix 5x86@100 VIP #-# Libretto 50CT #-# && 1x Sockel 8 & 3x Sockel4 (60MHz + 66MHz)

  • Das hört sich nicht tückisch an, sondern einfach falsch.
    Falls es überhaupt einen Geschwindigkeitsvorteil gibt, wie sieht es denn mit dem TRIM-Befehl aus?
    Win98 beherrscht den bestimmt nicht und ich kann mir gut vorstellen, das die Herstellertools nicht unter 98 laufen....

  • Es gab damals sicher schon Installationen auf Flashspeicher, aber dann wurde ein entsprechender Treiber des Herstellers mit geladen. TRIM ist natürlich auch noch so eine Sache, aber soweit sind wir ja gar nicht.


    Ich würde das Verhalten mit einer klassischen HDD gegen testen an dem Rechner.
    Ansonsten, hast du mal ein anderes IDE Kabel probiert. Anderer Anschluss? Hängt noch was an dem Kabel mit dran?


    Was auch noch ein Problem sein kann, ist die Menge an Ram. Mehr wie 512MB macht Win98 Probleme, zieh mal einen Ram raus und vergleiche.
    HIer steht etwas interessantes zu dem Thema:


    https://msfn.org/board/topic/1…indComment&comment=936270

    Meine Vintagerechner: XT (NEC V20) #-# Epson XT portable #-# HighScreen 286@16MHz #-# L&P 286-20MHz #-# Cyrix 386DRx²-33/66 #-# ESCOM Black Slim Am386DX@40MHz #-# IndustriePC Am5x86-133 #-# Cyrix 5x86@100 VIP #-# Libretto 50CT #-# && 1x Sockel 8 & 3x Sockel4 (60MHz + 66MHz)

  • Mal ´ne andere, vielleicht, doofe Frage:


    Wenn die SSD am SATA hängt, ist der Treiber der Schnittstelle installiert?


    Bei Windows 98 war, meines Wissens nach, solche Treiber extra zum installieren und nicht Teil des Betriebssystemes...

  • 512 laufen manchmal und je nach system instabil (größe des grafikkarten ram und anderen memory einstellungen)
    d.h. manche sachen laufen vll aber bei bestimmten sachen hängt er sich dann auf. je nach patches die auch schon installiert sind.
    aber wie gesagt das hängt auch stark von der verwendeten hardware ab.
    deshalb sind 256 immer save... 512 manchmal... drum lieber nur mit 256 testen.


    sata ssd nutzen paar ahci exklusive sachen, das könnte auch noch probleme machen (wenn der adapter das nicht umsetzt oder der controller nicht kann)

  • Ich denke auch, dass es am RAM liegt.

    Ich würde auch erstmal den Speicher auf 512MB begrenzen.
    Wenn die SSD am SATA hängt, muss der SATA-Controller im BIOS-Setup auf "Legacy" oder so stehen, dann sieht SATA aus wie eine normale IDE-Schnittstelle. Schau mal hier: https://msfn.org/board/topic/75258-chipset-support/
    Wie groß ist denn die Installationspartition auf der SSD? Zu groß darf die, glaube ich, auch nicht sein (32GB???).
    Kein CDROM im abgesicherten Modus ist normal, Win98 sieht da nur das, was auch unter reinem DOS sichtbar ist. Du kannst den CDROM-Inhalt am besten in ein temporäres Verzeichnis auf die Platte kopieren.

  • Ich werde das mit dem RAM mal versuchen. War auch eines meiner Hintergedanken, jedoch hab ich mal gelesen,
    dass WIN98 angeblich 1 GB ab kann!


    Das kurriose ist ja, warum funktioniert der abgesicherte Modus? Dann sollte ja nichts funktionieren!


    Ich werde morgen weiter berichten. Danke für die Denkanstösse ^^

  • Naja ich hab nen rechner mit 1,5 gb und 98 SE laufen... aber eben nicht mit den standard einstellungen und installiert habe ich ihn auch
    nur mit 256MB.


    Damals haben die Programmierer noch nicht dran gedacht, dass Rechner irgendwann mal mehr wie 512 MB Ram haben und dass es
    z.B. Grafikkarten mit mehreren Hundert MB RAM geben wird... usw.
    Ist ne lange Story aber unterm Strich ist ein 98 SE System nur stabil wenn System Ram + GPU RAM <= 512 MB liegen (also idealerweise 256+X)
    Es gibt ein paar Tricks wie man 98 dann mit mehr betreiben kann aber dazu muss man ein paar System files Ändern evtl. ne RamDisk anlegen usw..
    Gibt da ein paar echt gute Seiten dazu... ist aber bei mir auch schon ein paar Monate her, dass ich das zuletzt gemacht habe.

  • SSD+W98 läuft hier wunderbar - jedoch sollte man Optimierungsprogramme wie z.b. Taskmon abschalten.


    Anscheinend schmiert irgendein Treiber ab, das wird aber wohl eher am Chipsatz liegen. (Bootlog.txt bringt da etwas mehr Klarheit)


    Meine Empfehlung wäre: Windows erstmal mit minimaler Hardwareausstattung installieren (im Bios auch USB und ähnliches deaktivieren) - am besten von der HDD/SSD aus, dann kann dir das CDLW egal sein. Am besten gleich noch alle Treiber mit rüberkopieren.


    Was auch einen Versuch wert wäre DOS mit CD-Treiber starten und dann Windows per Kommandozeile im abgesicherten Modus starten.

    Von allen Dingen auf Erden ist die Intelligenz am gerechtesten verteilt: Jeder glaubt, er hätte genug davon.


  • Wenn das DVD laufwerk schon mal nicht erkannt wird dann hast du höchst wahrscheinlich eine inkompatibilität die schon im bios zuschlägt.
    Im bios, kannst du da den ide modus umstellen ?
    meist kann man das, man kann sata, compatible oder ide mode einstellen.
    unter win98 würde ich erst mal mit compatible oder ide probieren.
    der hase liegt in den bios einstellungen begraben !


  • Leute...


    "64 GB SSD, -> ATA <- (Transcend SSD370S)"


    Schade dass Blinken nicht geht ;)


    ___________________________


    Das dass DVD nicht geht kann auch an Windows liegen - wenn ich per Dostreiber von CD installiert hatte, hatte ich häufig anschließend kein CDROM in Windows - war allerdings W95...

    Von allen Dingen auf Erden ist die Intelligenz am gerechtesten verteilt: Jeder glaubt, er hätte genug davon.

  • falls du mich damit meinst:
    Mein Posting auch genau gelesen und verstanden ?


    Wenn das dvd im legacy mode erkannt wird und auch windows davon installiert werden kann, danach aber nicht mehr erkannt wird liegt das nicht immer am fehlenden treiber.
    wenn im bios der ide modus falsch eingestellt ist, dann wird das laufwerk unter windows nicht erkannt.
    damit es erkannt wird muss der richtige intel chipset treiber installiert sein, vorrausgesetzt der ide modus im bios ist richtig eingestellt ! INF_ME_98(6.3.0.1007).zip

  • aber dann folgt nochmals die Windows-CD-Abfrage

    hier hab ich noch n tipp:


    bevor du windows98 installiertst kopierst du dir die setup dateien auf die platte (bsp: C:\wincab) und startest das setup von der platte aus.
    smartdrv vor dem installieren nicht vergessen...
    setup /ID /IM /IS /IW macht das ganze etwas schneller.


    der vorteil hier ist das du auch im abgesicherten modus an deine windows 98 dateien kommst da die installationsroutine den source path in der registry entsprechend speichert.
    den source path kannst du aber auch bei einem bereits installiertem windows ändern.
    dazu öffnest du den registry editor und geht zu:


    HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Setup
    beim Eintrag "Sourcepath" gibst du den genauen pfad zum ordner der windows setup dateien an. (C:\wincab)


    letzteres könnte sollte bei dir funktionieren !

Jetzt mitmachen!

Sie haben noch kein Benutzerkonto auf unserer Seite? Registrieren Sie sich kostenlos und nehmen Sie an unserer Community teil!