Cyrix / TI 486SLC und QEMM386

  • Hallo, betreibt von eich jemand den Cyrix / TI 486SLC Prozessor in eine 386er Board und nutzt dazu QEMM386 als Speichermanager?


    Funktioniert das bei euch gescheit?


    Bei mir eigentlich nur, wenn ich die für den Prozessor verfügbaren Tools nicht nutze, um dessen erweiterte Fähigkeiten einzuschalten. Sobald der L1 Cache eingeschaltet ist, funktioniert QEMM FASTBOOT nicht mehr, sprich nach Drücken von STRG+ALT+DEL erscheint noch die Meldung, die Kiste bootet aber nicht mehr. Und wenn der L1 Cache eingeschaltet wird, hängt sich der QEMM-Optimize Prozess beim Booten an verschiedensten Stellen auf, selbst wenn ich den Reset-Taster drücke, oder die Kiste kurz aus und wieder einschalte. Da hilft dann nur noch, den Resetknopf direkt auf dem Mainboard zu drücken, und nicht den vorne an der Gehäusekonsole.


    Ich habe mir jetzt erstmal so beholfen, dass ich den L1 Cache der CPU in meiner win.bat vor dem Start von Windows ein und danach wieder ausschalte. (In der Batch erfolgt auch "net start" und der Aufruf der tigacd.exe für die Tiga-Grafikkarte, weil mir das alles für den normalen DOS-Betrieb zu viel RAM reserviert und nicht mehr ins UMB hoch geladen werden kann)


    Die Frage ist, ist das Verhalten mit dem L1-Cache beim TI486SLC normal, oder liegt das an meiner Olivetti-386er-Kiste (M380XP9, die hat L1 Cache onboard, der dadurch zum L2-Cache wird)?


    Nebenbei, die Kiste hat auch einen IIT387 Copro spendiert bekommen, ich suche aber noch einen Cyrix-Fastmath, der passt sicher besser zu dem Cyrix/TI 486SLC. Außerdem habe ich auch einen ULSI-387 Math Copro und würde für den ultimativen Vergleich auch noch einen originalen 80387-33 nehmen, wenn einer einen übrig hätte. Dann könnte ich mal in verschiedenen Kombinationen eure Benchmarksuite durchjagen.

  • Cool, ich habe 3 Stück davon Zuhause liegen und wusste nicht, dass man den L1 Cache extra einschalten muss :)


    Ich versuche mal dazu zu kommen und testen, ob ich gleiche Probleme haben werde, wenn Du mir sagst, wo ich die Tools für die CPU her bekomme. Und vielleicht noch kleine Einweisung.

  • Jetzt hab ich leider noch was doofes entdeckt, wenn ich den L1 Cache der CPU anschalte, funktioniert unter Windows 3.11 der Soundblaster-Pro(-Treiber) nicht mehr. Also besser den Cache immer aus lassen. X(

  • Wie hast du den einen SLC Prozessor auf ein Board bekommen das diesen nicht unterstützt ?


    Hast du im BIOS eine Cyrix 486 Option ? die SLC sind ja normal gelötet :-)


    Die Optionen vom Cache Tool hast du schon ausgereizt ?

  • So weit ich wieß, ist ein Cx486SLC ein drop-in replacement für einen 386DX. Zumindest hat der bisher überall funktioniert, wo ich den reingesteckt habe (bitte nicht falsch verstehen). Diese CPU war ja als "schnellste 386er" beworben damals und war als Upgrade gedacht, so weit ich weiß.


    P.S. Sorry habe es noch nicht ausprobiert.

  • Ja, habe gesehen, dass man da so einiges einstellen kann, aber da blicke ich noch nicht durch. Keine Ahnung welche Einstellung was macht und wo/wie das helfen könnte...


    Meine CPU ist kein SMD, und dieses Mainboard hat im Setup keinerlei Einstellmöglichkeiten für die CPU.

  • Haben die wenigstens 386 Mainboard.

    Spinnt es auch ohne FPU ? :-)


    Versuch mal das 1Mbyte ohne Cache laufen zu lassen.


    Hier mal das Cyrix Tool:

    cx486.exe


    EDIT:


    Hier vollständig, check doch mal den DMA Test


    https://www.pcorner.com/list/UTILITY/CYRIX15.ZIP/INFO/


    Eventuell ist das dein Problem:


Jetzt mitmachen!

Sie haben noch kein Benutzerkonto auf unserer Seite? Registrieren Sie sich kostenlos und nehmen Sie an unserer Community teil!