IBM 5170 mal anders

  • Hallo,


    ich wollte einmal mein IBM5170 Projekt vorstellen. Angefangen hat es vor über einem Jahr, als struuunz ein Schrottpaket entdeckte und wir es uns holten. Darin unter Anderem enthalten:


    Ein IBM 5170 Typ A mit erstem BIOS und 6MHz 80286er (Eigentlich wollte ich das Paket nur wegen diesem Board)

    Leider kam es recht unsanft behandelt an. Paar RAM Chips fehlten, bzw. waren abgeschert und verbogen:


    Und es gab viele Schürfwunden:


    Zu guter Letzt noch einen Akkuschaden von der Lithium Tonne (schon gesäubert, aber man erkennt die Korrusion):


    Nun denn, nachdem ich die gefundenen Unterbrechungen gefixt hatte, erst einmal eine Bank voll machen:


    Doch, kein Boot, nix, nur "-- --" auf der POST Karte.


    Noch einmal drüber schauen:

    Na, wer erkennt es?



    Dieser Pin war so verbogen, dass er den Lack durchstoßen und die Leiterbahn drunter kurzgeschlossen hat! Insgesamt habe ich b eim dann Hochbiegen aller eventuell so verbogenen Pins 3 solcher Stellen gefunden....


    Erfolg war, dass die Karte nun statt "-- --" "D0 03" anzeigte.


    In irgendeinem Forum habe ich gelesen, dass es der RAM ist. Naja, da ich viele RAM Chips gegenseitig getauscht habe, war ich mir sicher, dass es der 74ALS244 ist, also raus damit und testen:


    OK, der ist es alnso nicht. Ok, Sockeln:


    Dann habe ich versucht im laufenden Betrieb die Datenpins der Chis zu messen, ob eine Datenleitung auf GND/ VSS lagen oder irgendwie komisch waren. Dabei stellte ich fest, dass der oberste Chip sich anders verhielt, als der Rest. Chip getauscht --> das Gleiche. Dann den Sockel gemessen, ein PIN, der Datenpin, hatte nach Unten keinen Kontakt, oben im Bild ist er schon ausgelötet. Neuen Sockel reicn -->


    YEA! Wir haben ein Bild! Der neue Sockel fällt auch fast nicht auf. Was mir gerade aufgefallen ist, ich hatte ein AMI BIOS drauf gesteckt, weil es bessere Codes zur Fehlersuche ausgibt. 256k OK, und ab ins BASIC.


    Nun zum RAM, leider waren 2 Chips defekt. Hier an Ersatz zu kommen - nahezu unmöglich... Aber struuunz hatte noch 2 Chips für mich, um aud 512KB zu kommen - was braucht man mehr! (ok, spätr zum mehr RAM)


    Nun denn, im Schrott Paket lag auch der originale "Fixed Disk Adapter" von 1983. Also den rein, kein Tantal ist explodiert und er bootet von 1,2MB Diskette ins DOS, gleich einmal paar Benchmarks machen:


    1,7FPS!!! Da geht was!!! 6,85MHz AT mit nur 6MHZ!!! Eine FPU steckte natürlich auch noch drin - eine 6MHz Version, obwohl 5MHz genügen würden, anscheinend Funktional. 4,25MHz 80287. Sollten eigentlich 4,77MHz sein. Aber egal!


    Weiter geht es im Teil 2, später...

  • So, Mainboard ist fertig, Diskettencontroller ebenso. Was kommt jetzt, ja, eine Festplatte!

    MFM? natürlich!

    5,25"? natürlich!

    Volle Bauhöhe? ABSOLUT!!!


    Diese schicke Typ12 Festplatte konnte ich mir letztes Jahr "fischen" - Dank struuunz wurde ich auf die Anzeige aufmerksam.


    Geschwind am Testplatz testen:


    Laüft, Defekte Sensoren erst einmal nur am Ende. Kann man mit leben...


    Im IBM habe ich das originale BIOS wieder eingesetzt:


    Und die MFM am originalen Controller formatiert (auf die RAM Karten gehe ich nachher noch ein):

    Lüppt!


    Hihi, dann etwas zocken:


    So, etwas blöd nur, dass das BIOS ohne 6V Batterie keine Daten hält... Und das BIOS Setup gibt es nur von Diskette. Also eine neue 6V BIOS Batterie. Man, die großen sind teuer und halten auch nicht lange, da das Mainboard recht viel Strom zieht. Habe 120µA gemessen. Die billige Variante, 2St CR2032, wären also innerhalb 1666h leer (200mAh). Hmm. 2 LiIo Akkus bekommt man billig, bzw. kostenfrei aus einem alten Notebook Akku. Auch ziemlich nieder haben die noch >1000mAh. Meine Lösung:


    2 Stück Notebook Akkus in Reihe, ein Step Up Wandler, der 8,2V aus 5V macht. Ein 5V Relais, dass sich öffnet, wenn der PC aus ist und ein Ladewiderstand, der den Ladestrom begrenzt. Danach ein 7,5k Widerstand und 2 Dioden in Reihe. Bei vollem Akku und aufgesteckt kommen genau 6,4V raus perfekt. Die Akkus haben noch 2000mAh und der Ladestrom beträgt max. 1,5A. Theoretisch reicht es alle 2 Jahre einmal den Rechner für 1h einzuschalten, um den Akku voll zu halten.


    Weiter geht es dann später im 3. Teil.

  • Man das ist mega spannend zu lesen weiter so!🙂

    Am meisten hat es mich überrascht, was man so aus alten Akkus machen und ohne weiteres einen anderen BIOS Baustein reinpacken kann😲

    GA-586TX-3 Mainboard (Intel 430TX)

    K6-2 400 CPU AFQ (6x66mhz)

    128MB Ram

    Matrox G450 32MB + Voodoo 1 4MB

    4x USB 2.0 hub PCI

    Fastrack Ultra 100 PCI

    80gb HDD

    Sound Blaster Pro 2 CT1600

    (Wird bei Zeiten alles auf ein GA-586HX umgesteckt wenn genug edo Ram gefunden wird)


    Der Opa:

    Tandon 286 PC, 8mhz, 1Mb Ram, 512k Vga & 40MB RLL HDD

  • ich wollte lediglich nur meinen riesiges Lob aussprechen für die geile Arbeit😄

    GA-586TX-3 Mainboard (Intel 430TX)

    K6-2 400 CPU AFQ (6x66mhz)

    128MB Ram

    Matrox G450 32MB + Voodoo 1 4MB

    4x USB 2.0 hub PCI

    Fastrack Ultra 100 PCI

    80gb HDD

    Sound Blaster Pro 2 CT1600

    (Wird bei Zeiten alles auf ein GA-586HX umgesteckt wenn genug edo Ram gefunden wird)


    Der Opa:

    Tandon 286 PC, 8mhz, 1Mb Ram, 512k Vga & 40MB RLL HDD

  • Beckenrand-schwimmer


    Hervorragende Arbeit! Lob und Anerkennung!


    Hab ja auch einen genuine IBM 5170 6 MHz mit 5151 Green Screen wie du weißt...


    Da sollte auch mal eine Full Height MFM rein, nämlich eine Zweite :D


    Deine ehemalige FH MFM kommt in den Micro 8088.

    :freak RetroComputerPoPe - Dr. (Ehrenhalber) Darius von Bernstein - Grünstein - Lötstein :freak


    * Bezwinger der EIZO ( ͡° ͜ʖ ͡° ) *


    Päpstlicher DOSianer mit mittlerweile jeder DOS-Architektur (XT/286/386/486/586/686...)
    Status: Don't mess with the RetroPoPe / Erweiterter Amateur mit der unoffiziellen Bräter-Lizenz *g*

  • Diese Variante mit den Chips stapeln gab es doch auch mal "irgendwo" als "nachrüst" RAM Expansion mit hochgebogenen Adress Beinen direkt mit Litze am Speicher Controller. Hab ich irgendwann ende der 90iger mal gesehen evtl. Amiga? keine Ahnung hab das aber als "üblicher" Umbau bei diesen Rechnern in Erinnerung ???

    386SX- 20 Mhz "Erster eigener Rechner!2" NoName Komponenten

    486DX -30 "Industrie PC" auf Steckkarte

    Super Sockel 7 Gigabyte GA-5AA 3Dfx Voodoo 3500 TV

    AMD "Geode" ebenfalls Steckkarte für Backplane

    3x IBM Netvista 8364 "ThinRetroSystem" 1-2 von denen würde ich tauschen...


    "und noch so einiges mehr... "

  • So, weiter geht es mit der Vorstellung. Was haben wir bereits? Ja, ein Mainboard mit satten 512k RAM, ein 1,2MB Laufwerk und eine Festplatte.

    Was fehlt? Ja, mehr RAM!


    Um noch mehr RAM zu haben müssen erst einmal die 128k von 512k zu 640k aufgefüllt werden. Der IBM unterstützt zwar auch XMS Speicher, wenn er nur 512k hat, allerdings kann er keinen Speicher über 1M zurück mappen.

    Es gab diese 128k Speichererweiterung - kaum zu bekommen. Selbstbau - möglich aber bäh!


    Aus dem alten Forum hatte ich vor ein paar Jahren eine Karte bekommen, die allerdings nicht laufen wollte, ein Info-PC Karte von 1985:



    Eine absolut geile Karte, ich dachte, dass diese 2,5MB hat. Jedoch weit gefehlt! Beim genaueren Hinsehen:


    Ja, es gibt 72 St. 1x256k und 18St 1x64k. Also einmal 2MB und einmal 128k!! Ah!


    Im IBM läuft die Karte auf Anhieb! zumindest die ersten 128k. Der Rechner zeigt nun 640k an.


    OK, die Karte hat jetzt sehr viele Switches. Da ist Geduld gefragt. Es gibt da ein Programm, welches den kompletten Adressraum nach RAM scannt:


    FF bedeutet, dass da nix ist. Am AT dauert ein Durchlauf schlappe 30min. Am 486er nur 4 :) deswegen habe ich die Karte in einen mit 1MB bestückten 486SX-25 gestopft.

    Nach vielen Versuchen:


    Habe ich die korrekte Jumperstellung herausgefunden und die Bedeutung der meisten Switches:


    Die Fehler im Speicherbereich sind nur, weil ich Chips gezogen habe, um zu sehen welche Bank was ist auf der Karte.


    Taataa, ich habe 2MB XMS!!!



    Sehr genial! Die Karte hat 1985 wahrscheinlich ein Vermögen gekostet. Die 64k Chips sind durchweg KW15/ 1985 und 36 (1MB) der 256k Chips KW29/1985. Das zweite Megabyte wurde anscheinend 1990 nachgerüstet (KW08/1990).

  • Wo ziehst du denn immer die Speicherkarten, Controller und MFM-Platten her, Wahnsinn 8o


    In deinem Keller müssen ja unvorstellbare Speichermengen lagern, bestimmt mehrere Hundert MB.

    Und davon ganz viel! Da bin ich mir sehr sicher.

    :freak RetroComputerPoPe - Dr. (Ehrenhalber) Darius von Bernstein - Grünstein - Lötstein :freak


    * Bezwinger der EIZO ( ͡° ͜ʖ ͡° ) *


    Päpstlicher DOSianer mit mittlerweile jeder DOS-Architektur (XT/286/386/486/586/686...)
    Status: Don't mess with the RetroPoPe / Erweiterter Amateur mit der unoffiziellen Bräter-Lizenz *g*

  • So, dann noch die Festplatte gesäubert:


    Und den MFM Controller getauscht, da der originale leider einen Konflikt mit dem SCSI Controller verursacht hat, den ich einbauen wollte:

    Oben Version 1 des Controllers, unten die neuere Variante.


    Jo, passt auch.


    Dann bekam ich noch einen schöneren, der auch noch einen COM und einen LPT Port hatte:

    Natürlich schön groß!

    Leider war der COM nicht raus geführt...


    Also schnell nachrüsten. Zum Glück habe ich Bilder gefunden, dass es die KArte in mehreren Versionen gab:


    Also die Bestückung ist immer gleich, egal, ob der interne oder externe Port genommen wird.



    Und: Maus funktioniert!

Jetzt mitmachen!

Sie haben noch kein Benutzerkonto auf unserer Seite? Registrieren Sie sich kostenlos und nehmen Sie an unserer Community teil!