Bitte einen Tipp: welche Distro 32bit?

  • Hallo Ihr.


    Ich habe hier zwei alte Laptops - einmal ein Thinkpad T43 (TP)mit 1GB RAM und dann noch ein Fujitsu Siemens Amilo (FSA), 2GB. Letzteres war ein Giveaway hier aus dem Forum. :)

    Ich brauche einfach ein Gerät, was ich mal nebenher für Internet und Videos nutzen kann, FullHD tut nicht Not.

    Beide haben PAE, also daran scheiters nicht.


    Hier meine Odyssee:

    Linux Mint knackt die ganze Zeit während der Installation (habe ich gegoogelt, bekanntes Problem). Nach dem Neustart kein Bild mehr. Sparky Linux lässt sich nicht installieren. Zorin OS lässt sich installieren - ABER! Egal, was ich dann über die Paketverwaltung installiere - es startet nicht. Gestern dann MXLinux.... und ich habe immer den Fehler, dass die Installation bei 95% stehen bleibt und meckert, GRUB könne nicht installiert werden. Auch das Problem haben viele andere und scheint die Krücke dieser Distro zu sein.

    Debian... läuft, findet aber den WLAN-Adapter des Thinkpads nicht... das raffe ich ja mal gar nicht, das haben die anderen Distros alle hinbekommen.


    Ich bin kein Linuxer. Ich habe - WENN - immer Linux Mint genutzt. Das startet man, installiert es und der Rechner läuft.

    Zuletzt noch auf einem kleinen PackardBell-Nettop, auf dem vorher total zäh Windows 8.1 lief. Stick dran, gebootet, installiert, läuft.

    WLAN, Codecs, alles da.

    So hätte ich das gerne auch für meine anderen Rechner, ich glaube, ich werde mich in diesem Leben nicht mehr mit der Kommandozeile anfreunden können.


    Lubuntu habe ich erst mal weggelassen, das scheint ja noch auf Ubuntu 18.04 zu basieren... und Linux Mint 18.04 lief auf dem FSA - aber es ist eben nicht mehr aktuell. Bei dieser Distro gabe es auch kein Geknacke während der Installaiton.


    Ich habe wirklich schon viel gegoogelt und ausprobiert - und ich kann einfach nicht glauben, dass es nicht eine Distro gibt, die man ohne großes Gefrickel booten und installieren kann... und die dann auch läuft? :)


    Gibt es da draußen eine Distro, die hier zu empfehlen wäre?

    Ich entschuldige mich mal pauschal hier für "dumme" Fragen... ich bin kein "Löter" und deswegen hier mehr ein N00b. :)

    Gruß, cp2



  • also im Grunde genommen: tausche \ mit /, dir mit ls und vergesse das " " nicht bei cd.. und das wars eigentlich auch schon...

    Ohne das jetzt zu groß ausführen zu wollen... aber ganz so leicht ists halt nicht. Benutzerfreundlich ist die Shell nicht wirklich. Da ist DOS der reinste luxus.

  • Du sagst es. Ich hacke seit C64-Zeiten Kommandos in Rechner und habe mir in DOS damals auch selbst mit allem geholfen.

    Linux kam, als Windows schon DOS ersetzt hatte,


    Ich installiere auf dem TP gerade Linux Mint 19.0wasauchimmer.... und zum x-ten Mal tritt der Fehler auf, dass beim Lesen ein input/output-Error aufgetreten sei, von wegen schlechtes Medium... Von dem Stick habe ich auch den Packard-Bell installiert, MD5 stimmt auch, also ist die Fehlermeldung Dünnpfiff.


    Ist echt nicht wirklich spaßig...


    Nachtrag: Windows 2000 lief übrigens einwandfrei auf dem TP, aber das taugt ja heute fürs Internetz nicht mehr.

    Ich entschuldige mich mal pauschal hier für "dumme" Fragen... ich bin kein "Löter" und deswegen hier mehr ein N00b. :)

    Gruß, cp2



  • controlport2 die closed source Firmware ist in Debian aus Grundsätzen der Distribution abgeklemmt, da sie versuchen nur freie Software zu unterstützen. Du musst dem System erst erlauben die Firmware zu installieren. Dafür musst Du in der Datei /etc/apt/sources.list das non-free repository hinzufügen. Suche nach einer ähnlichen Zeile, wo am Ende main contrib steht und füge da non-free dahinter ein.


    Also z.B.:

    Code
    Aus:
    deb http://http.us.debian.org/debian stable main contrib
    
    Mach:
    deb http://http.us.debian.org/debian stable main contrib non-free


    Danach machst Du:

    Code
    sudo apt update
    sudo apt install firmware-linux-nonfree firmware-ipw2x00

    Danach System neu starten und dein WiFi sollte laufen.


    EDIT: Es gibt viel Dokumentation dazu. Einfach nach "non-free debian" suchen. z.B. hier

  • Ich nutze auf meinen 32-bit Kisten ANTIX.

    Läuft recht zügig und bis jetzt hatte ich noch keine Probleme.

    Daily Driver: MSI X470 Gaming Plus - Ryzen 5 1600 - 16 GB - Geforce GTX 1060 6GB - 1 TB NVMe SSD - 2 x 1 TB Raid-0 SATA

    Projekt #1: ASI 486-33 - Projekt #2: PC Chips M912 486 VLB - Projekt #3: Biostar MB8500TVX-A Pentium MMX 166 - Projekt #4: ASUS TXP4 K6-III 400 - Projekt #5: Gigabyte GA-6BXDS Dual Slot 1 PIII-650 -

    Projekt #6: ASUS P2B-DS Dual Slot 1 PIII-1000 - Projekt #7: Gigabyte GA-6VXD7 Dual Sockel 370 PIII-1000 - Projekt #8: TYAN S2505T Dual Tualatin 1400

  • Das dritte!??! :whistling: :D


    Nein, Schmarrn, schon klar. Ich wollte jetzt nur ganz sicher gehen, bevor das wieder nix wird.

    Danke für Dein Aufs-Fahrrad-Helfen oben, das teste ich mal und melde mich wieder!

    :thumbup:

    Ich entschuldige mich mal pauschal hier für "dumme" Fragen... ich bin kein "Löter" und deswegen hier mehr ein N00b. :)

    Gruß, cp2



  • Toll.

    Beim Schreiben mit Rufus auf den USB-Stick kommt die Meldung, der Datenträger würde von einem anderen Prozess ("Windows Explorer") benutzt.

    Also nochmal... jetzt ist der Stick angeblich schreibgeschützt und ich bekomme ihn nicht mehr beschrieben... es soll irgendwie nicht sein...

    Wo ist die Kamera??? :D :D

    Ich entschuldige mich mal pauschal hier für "dumme" Fragen... ich bin kein "Löter" und deswegen hier mehr ein N00b. :)

    Gruß, cp2



  • Toll.

    Beim Schreiben mit Rufus auf den USB-Stick kommt die Meldung, der Datenträger würde von einem anderen Prozess ("Windows Explorer") benutzt.

    Also nochmal... jetzt ist der Stick angeblich schreibgeschützt und ich bekomme ihn nicht mehr beschrieben... es soll irgendwie nicht sein...

    Wo ist die Kamera??? :D :D

    Stehst unter keinem guten Stern gerade. Nimm Dir ein Bier und entspann Dich :D

  • Das hatte ich gerade vorhin auch.


    Rufus ausmachen, den explorer schließen - hat autostart denn ggf. aufgemacht?

    rufus wieder anmachen dann sollte es gehen.

    Ich musste gerade das iso von Netrunner von einem Netzlaufwerk zum andern schieben weil Rufus keine Lust hatte mit denen zu reden.

    “My name is not spoken,” she replied, with a great deal of haughtiness. “More than a hundred years it has not gone upon men’s tongues, save for a blink. I am nameless, like the Folk of Peace. Catriona Drummond is the one I use.”

  • Etcher hatte ich auch schon mal irgendwann.

    Aber heute ist wohl nicht mein Tag...


    .... nein, es tut sich nichts, gar nichts.... und ja, der Rechner läuft sonst einwandfrei. Etcher ist das erste Programm, was nicht läuft.


    edit: mit Rufus hat es jetzt geklappt. Dann mal rüber zum Thinkpad... bis später. :D

    Ich entschuldige mich mal pauschal hier für "dumme" Fragen... ich bin kein "Löter" und deswegen hier mehr ein N00b. :)

    Gruß, cp2



    Einmal editiert, zuletzt von controlport2 ()

Jetzt mitmachen!

Sie haben noch kein Benutzerkonto auf unserer Seite? Registrieren Sie sich kostenlos und nehmen Sie an unserer Community teil!