Netzwerk unter Dos einrichten und nutzen.

  • Wir hatten uns in diesem Thread http://dos-reloaded.de/forum/i…s/?postID=11400#post11411 über die daemon tools unterhalten.
    ich schrieb das ich meine isos übers netzwerk mounte und wurde danach gefragt wie ich das löse.
    nun dachte ich mir das ich in dieser richtung mal einen thread erstelle in dem es sich um windows netzwerke und deren nutzung in den verschiedenen betriebssystemen handelt.


    icb gehe mal sehr stark davon aus das jeder weis wie man ein tcp netzwerk unter windows/dos/98 einrichtet.
    besteht hier bedarf ?

  • Bei mir gibt es kein NAS und schon gar keine Fritzbox.


    Der Retro-Server ist ne Athlon64 3000 gurke auf einem Asrock dual sata2 board mit 2 gb ram und 4 festplatten (raid 1)
    (Er wird demnächst einem Intel System weichen müssen )


    Auf dem Rechner läuft Windows Xp mit Sp3 ohne weitere Spielereien.
    Xp ist ganz normal mit meinem Heimnetzwerk verbunden, ich kann mit dem Ding also auch ins Internet gehen.
    Netzwerkfreigaben funktionieren in Richtung des Retro-Servers aber nicht umgekehrt. (Ich weis, es gibt Lösungen dafür aber die Arbeit mache ich mir erst gar nicht.)


    Der Retro-Server steht im Keller und wird bei bedarf eingeschaltet.
    Administriert wird er per Windows Remote Desktop.
    Wenn ich neue Daten vom Internet oder anderen quellen habe dann kopiere ich diesem auf meinen Home-Server (i7 4770k 32gb ram) und schiebe sie dann auf den Retro-Server.


    Den Inhalt des Retro-Servers habe ich auf einer VMware gespiegelt.
    Im Prinzip ist der VMware Server das gleiche wie der echte Server.
    Die VMware wird alle 4 Wochen automatisch aktiviert ebenso der Retro-Server.
    Batchdateien erledigen die Synchronisation (verschiebe von "a" nach "b")


    Meine ganzen Retro Systeme sind mit einer statischen IP eingestellt, macht das booten etwas flotter.
    Außerdem habe ich auf jedem der Systeme ein Bootmenü mit dem ich beim booten das Netzwerk aktivieren kann.
    Da die ganzen TSR und Netzwerk Treiber/Programme recht viel speicher ziehen kann man nicht immer das Netzwerk aktiv lassen wenn man spielen will,
    hier wird dann im Bedarfsfall die ganze ISO Datei des Spiels auf die Festplatte kopiert.


    Die iso Dateien per dos zu mounten geht mit dem Programm shsucdhd.
    mit mscdex kann man diese dann einbinden.
    die meisten Spiele laufen bei mir im Dosfenster von Windows 95/98/me
    hier lässt sich sehr bequem mit den daemon tools arbeiten.
    wenn man ein wenig mit den pif dateien herumspielt lassen sich hier schon recht viele spiele installieren und starten.
    windows 95 hab ich auch auf meinem kleinsten windows rechner laufen, ein dx2/66
    ich weis, es geht auch noch kleiner in der leistung aber ich bin kein masochist :D

  • <---bedarf mit schneller und unkomplizertem step by step tutorial. Aka: ich hau ne ISA-Lankarte rein, stöpsel das ethernet kabel rein und an den router/Switch, let's go :)

    Im Prinzip ist es so :D


    Man braucht für DOS only die zwei Disketten welche Microsoft anbietet.
    hier findet man eine bebilderte Anleitung wie man das ganze einrichtet, die disketten sollten dort auch zum downloaden sein.


    Die Netzwerkkarte sollte eine gängige sein und man sollte die "Disable the Automatic Configuration" auf "1" stellen, das sorgt für eine schnellere Bootzeit.
    Hier muss allerdings die IP, Subnetmask, Gateway und der DHCP Server von Hand eingetragen werden

    Zitat

    Lankarten mit AUI/BNC und 10BASE-T Anschluss sollten per software auf Autochange bzw. 10BASE-T eingestellt sein ansonsten könnte es durchaus passieren das man es da echt an die Nerven kriegen kann wenn das verfluchte Netzwerk nicht Funktionieren möchte. :Kabudd
    Hier ist ein passendes Programm für die Lankarte erforderlich, es gibt keine Universalprogramme dafür zumindest sind mir keine Bekannt

    Ne2000 kompatible karten Funktionieren auch.
    Ebenfalls habe ich super Ergebnisse mit 3Com Lankarten erzielt.
    Hier lässt sich einfach alles mit den eingangs beschriebenen Disketten einrichten, eine extra Treiber Disk ist da nicht mehr notwendig.


    Nach der Installation und dem ersten Reboot wird man nach einem Usernamen und Passwort gefragt,
    ich gebe hier immer xxx und bestätige das passwort mit "2xenter" denn egal was ich hier eintippe ab windows XP ist kein Netzwerk mit Dos mehr möglich bzw. mir ist keine Lösung bekannt die funktioniert
    Weiter, nach der Installation das Netzwerk prüfen in dem man mit dem "Ping" befehl den Router anpingt.
    Wenn alles richtig eingestellt ist dann sollte der "Ping" beantwortet werden.


    Mit dem Befehl "Net view \\SERVERNAME" sieht man die Freigaben des Servers
    Mit dem Befehl "Net USE LAUFWERKSBUCHSTABE: \\SERVERNAME" kann man die Frei gegebenen Ordner mit Laufwerks Buchstaben in DOS nutzen.
    Nach einem Reboot wird das Laufwerk wieder eingebunden.


    Man kann auch auf dem DOS Rechner entsprechende Ordner freigeben, ich habe dies bisher aber nur einmal zu Testzwecken eingestellt und nie wirklich gebraucht.
    Hier müsste ich nochmal in der Readme Datei nachlesen wie das geht denn das ist schon ein paar Jahre her...

  • Linux hatte ich auch schon im Auge aber absolut keine Ahnung wie man dies überhaupt bedient.
    Ein Ubuntu bekomm ich installiert und wenn es sein muss auch noch ein Netzwerk damit das ding ins internet kann aber das war es dann auch schon.
    Linux war für mich immer ein buch mit 7 siegeln

  • Das Thema passt ja grad wunderbar zu dem was ich gerade probiert hab. Ich hab auf meinem Bastelboard, UM8810PAIO, DOS 6.22 und Windows for Workgroups 3.11 auf einer CF Karte installiert und wollte eine Ne2000 ISA Netzwerkkarte installieren. Karte wird von Windows erkannt und ließ sich mit der Windows Installations CD problemlos installieren aber danach startet Windows nicht mehr und bleibt beim blauen Startbildschirm hängen. Gleiches passiert auch mit einer SMC ISA Karte. Karte raus und es geht wieder.


    Hattet ihr schon mal dieses Problem?

  • Wenn ich raten müsste, ist es ein Speicherkonflikt der win Treiber.


    Ich würde so vorgehen....


    Das Board hat doch auch PCI? Versuch mal da eine Netzwerkkarte (PCI belegt andere Ressourcen.)


    Kannst du im Bios dem ISA Slot Werte zu teilen?


    Win 3.11 mit dem Schalter '/N' (ohne Netztwerk) starten um die Möglichkeiten ein zu grenzen


    Win mit den RealModus Netztwerktreibern konfigurieren:
    Programmgruppe NETZWERK starten, dort das NETZWERK-SETUP anklicken. Dann die Schaltfläche TREIBER, und mit der linken Maustaste auf deine Netzwerkkarte zur Schaltfläche EINSTELLUNGEN...unter dem Punkt TREIBERTYP, die Einstellung REAL-MODUS NDIS-TREIBER ein.stellen...Neustart.


    Ist aber echt schon lange her :)

  • Kann es sein, dass Windows nach einen DHCP Server sucht. Wie lange hast du beim Starbildschirm abgewartet?
    Ich kann mich erinnern, dass das Timeout bei den frühen Windows Versionen ziemlich hoch war, bevor es weiter geht (1-2 min.)

  • Gut...für den Fall dann Windows mit dem Schalter /B starten und in der Bootlog.txt nach den Treiberabläufen schauen.
    Ich entsinne mich, dass die Zeile : LoadFail = NETAPI.DLL Failure code is 02
    mich recht viel Neu-Installations-Zeit gekostet hat :)

  • wär gut :) Und gut zu wissen wär wie die Treiber geladen werden? Kommt da was in die config.sys und so ? Weil die schöne aufgeräumt ist bei mir :) Und wieviel speicher nimmt das Teil weg und gibt es speichersparende alternative Treiber?


    Fragen über Fragen ^^

  • in der config.sys kommt nur ifshlp.sys


    in der autoexec.bat sind es um die 10 programme welche geladen werden.
    ich uppe heute mittag/abend mal meine autoexec.bat in der man ein kleines menü hat.
    auf jeden fall, wen das netzwerk läuft hat man noch ca. 350kb - 400kb konventionellen speicher frei.

  • Habe mich den halben Nachmittag mit einem Defekten Bioschip beschäftigt und dies hier total vergessen, sorry


    Die Autoexec.bat meines 286ers


    Die Config.sys meines 286ers

    Code
    device=c:\dos\himem.sys /a20control:on
    dos=high,umb
    FILES=20
    STACKS=9,256
    Device=C:\dos\ansi.sys
    device=C:\NET\ifshlp.sys
    LASTDRIVE=Z


    ansi.sys nutze ich für die Formatierung des Dos Prompts.
    Grün = netzwerk
    Gelb = normal

  • Hier mal eine kleine Anleitung wie man ein TCP Netzwerk unter DOS einrichtet.
    Ich habe dies auf einer VMware gemacht, geht schneller und es ist einfacher Screenshots zu machen.
    Bis auf den Treiber der Netzwerk Karte sind die Vorgänge zu 100% Identisch.


    Vorraussetzung ist DOS 6.22 einen passenden LAN Treiber (Ne2000 Kompatibel und die 3Com Karten sind auf den Disketten enthalten)


    Wir haben die Disketten entpackt und starten die Setup Routine.
    Wir drücken Enter...


    Jetzt wird ein wenig kopiert.
    dazwischen oder etwas später werdet ihr nach einer Diskette gefragt, ihr wechselt entsprechend.
    (ich habe meine Netzwerk Setup Dateien, also beide Disketten entpackt im gleichen Ordner, auf CDrom liegen und installiere das Netzwerk auch von CDrom, eine diskette brauche ich nicht wechseln ich werde auch nicht gefragt)



    Irgendwann wird nach der Lan Karte gefragt.
    Ich wähle hier "Not Shown..." aus da der AMD Adapter der Vmware hier nicht gelistet ist.
    Wie ihr seht gibt es schon einige Karten/Treiber in der Liste



    Ich wähle den AMD Treiber...


    die Folgende Meldung sagt, das mehr Buffer´s auch mehr Speicher benötigen.
    Weniger Buffers verringern den Datendurchsatz, als am besten erst mal so lassen.



    Als nächstes werden wir nach einem Usernamen gefragt.
    Sicher ist das wichtig aber für unseren Fall nicht, hier könnt ihr eingeben was Ihr wollt !


    Nachdem wir einmal wieder Enter gedrückt haben sehen wir das hier...



    Wir gehen auf "Change Names" und geben unserem Rechner erst mal einen Namen.
    außerdem nehmen wir auch den Namen des Windows Netzwerks, also die Workgroup.
    Bei mir heißt die Workgroup "Worker" und der Dos Rechner nennt sich VMWARE_DOS


    Nachdem wir "The listet names are correct" ausgewählt haben sind wir wieder im "Hauptmenü"
    Jetzt gehen wir in den Abschnitt "Change Network Configuration"


    Wir sehen dann das hier...oder auch nicht...denn im Normalfall steht hier noch ipx/spx, das könnt ihr löschen.



    Mit der TAB Taste kann man hier zwischen dem oben und unteren teil wechseln, kann einem auf die nerven gehen :D


    Wir wählen oben "Microsoft TCP/IP" aus und unten gehen wir auf "Change Settings"
    Wir sehen dieses Menü und wir stellen Die "Disable Automatic Configuration auf "1" "


    Weiter, stellen wir als TCP Adresse eine freie Adresse in unserem Netzwerk ein.
    Anstatt eines Punktes wird ein Leerzeichen verwendet, Überall !!!!
    Hier müsst ihr euch schlau machen in welchem bereich ihr euch befindet !!!


    Wir stellen die Subnetmask ein und wir stellen das Gateway (euere Router IP) ein.


    Anschließend gehen wir mit "The listet Options are correct" wieder in das "Hauptmenü"
    Und hier bestätigen wir ebenfalls mit "The listet Options are correct", das kopieren und konfigurieren geht weiter.


    Nach einer weile sollte diese Meldung kommen...


    Nach einem Reboot sollte es dann ungefähr so aussehen...und wir drücken Enter.


    Wir drücken wieder Enter


    Wir drücken "Y"


    Wenn ihr alles richtig eingestellt habt dann sollte das Netzwerk laufen.


    Mein Retro-Server läuft auf XP basis.
    Mit dem befehl "net view \\Retro-Server" sehe ich die Freigaben des Servers


    Wenn ich nun "net use t: \\retro-server\treiber" eingebe dann stelle ich eine Verbindung mit einem Laufwerksbuchstaben mit meinem Server her.



    Mit dem Befehl "net use" sehe ich die Laufwerke bzw. Buchstaben welche auf dem Dos Rechner angemeldet sind.

  • Top, Danke Wolle.

    Meine Vintagerechner: XT (NEC V20) #-# Epson XT portable #-# HighScreen 286@16MHz #-# L&P 286-20MHz #-# Cyrix 386DRx²-33/66 #-# ESCOM Black Slim Am386DX@40MHz #-# IndustriePC Am5x86-133 #-# Cyrix 5x86@100 VIP #-# Libretto 50CT #-# && 1x Sockel 8 & 3x Sockel4 (60MHz + 66MHz)

  • Hier mal ein kleiner Zwischenbericht zu meinem Win 3.11 Problem:


    - Nach ca. 5 min Wartezeit passiert immer noch nichts, der blaue Startbildschirm bleibt da
    - Bei win /n startet Windows ohne Probleme.
    - In der Bootlog.txt steht der gleiche Fehler wie bei Heilbar: LoadFail = NETAPI.DLL Failure code is 02
    - Der Treibertyp ist standardmäßig auf Real-Modus und erweiteter Modus NDIS-Treiber eingestellt


    Für die PCI Karte muss ich erst noch nach Treibern suchen. Das werde ich jetzt gleich noch machen.

Jetzt mitmachen!

Sie haben noch kein Benutzerkonto auf unserer Seite? Registrieren Sie sich kostenlos und nehmen Sie an unserer Community teil!