[erledigt] Wie kann man beim GA-7IXE den Parallelport deaktivieren und das SBA testen?

  • Ich schaffe es einfach nicht, beim GA-7IXE den Parallelport komplett abzuschalten.
    - Obwohl im BIOS unter Integrated Peripherals alles, was mit parallelen und seriellen Schnittstellen zu tun hat, deaktiviert ist, erkennt Win98SE immer noch einen ECP-Parallelport und blockiert dadurch IRQ7 und DMA1.
    - Deaktivieren der Schnittstelle im Gerätemanager schaufelt den IRQ7 auch nicht frei.
    - Entfernt man den Port aus dem Hardwareprofil, wird er nach einem Neustart wieder erkannt und neu eingerichtet.
    - Habe eben das BIOS von F3 auf F7 (neueste) aktualisiert, brachte aber keine Besserung.


    Da in den Rechner eine GUS rein soll, hätte ich gerne so viel wie möglich frei, zumal ich den Parallelport eh nicht brauche. Habe schon erfolglos verschiedene Einstellungen von "Auto" über "Standardmodus" bis "Disabled" ausprobiert.
    Beim GA-6BXC und CUSL2 ist das kein Problem und funktioniert wie gewünscht.


    Wer weiß Rat?


    Immerhin wurde laut Everest Home 2.20 durch das BIOS-Update der AGP 2x-Modus und das Sideband-Addressing (SBA) des AGP aktiviert. Letzteres soll ja laut elinda dazu führen, daß das System einfriert.


    Wie kann ich testen, ob das SBA wirklich funktioniert?


    Übrige Komponenten:
    Athlon "Pluto K75" 1000 MHz
    192 MB SD-RAM PC100 CL2 Micron Technology
    ATi Rage Pro Turbo 2xAGP (nur vorübergehend bis das System wie gewünscht läuft, dann kommt eine Voodoo5-5500 rein)
    6 GB HDD Western Digital
    DVD-RW LG(?)
    3,5" 1,44 MB Floppy Sony
    350 W NT Seasonic


    Win98SE ohne Patches
    Win98Plus!
    AMD-Chipatztreiber für GA-7IXE von Gigabyte-HP
    ATi-Ragetreiber 4.11.2560 von ehemaliger ATi-HP

    Ich werde mich von keinem einzzzigen Prozzzessor trennen.
    Jedoch lockt es mich beinahe, ihn Dir zu überlassen, nur um zu sehen, wie er Dich in den Wahnsinn treibt :evil:


    Meine Begehren

  • Zuerst fest stellen, ob das ein Windows Problem ist oder ein Bios Problem.


    Beim Hochfahren...werden da die Komponenten (falls er zu schnell in Win springt, mit Dos Boot Disk starten) angezeigt?
    Sonst auch mit MSD (Diagnoseprogramm von DOS) das Vorhandensein der Schnittstelle auslesen.


    Ein Jumper oÄ findet sich ja nicht auf dem Board?

  • Und bevor man Windows da auf die Schliche kommen muß, warum sich die IEEE-1284-Schnittstelle da nicht deaktivieren lässt,
    könnte man auch mit dem Gedanken spielen, Ressourcen ruhig doppelt zu belegen mit der Gus, solange sie nicht doppelt angesprochen werden.


    Eventuell lässt sich bei einer Doppelbelegung, wenn die Gus erst eingebaut ist, auch dann erst durch das Konflikteigenschaften-Managment in '98 ein Abschalten/Umkonfigurieren einrichten.


    Eine manuelle Umprogrammierung unter Linux der DMA oder IRQ Steuerung ist mir nicht bekannt. Auch ein hardware-nahes Abschalten der Schnittstelle durch Kabelbrückung wär mir neu. Ich hab mal mit dieser Parallelen Schnittstelle, durch Brückung bestimmter Pins ein Bios Reset geschaltet zur Passwort Löschung...aber sonst...?

  • Interessantes Problem.


    Laut dem Handbuch scheint aber entweder IRQ 5 oder 7 für den PP vergeben zu werden. Eventuell könnte dieser aber auch fest vergeben sein, ergo du wirst ihn so nicht loswerden.


    Hast du mal versucht, ihn in der PCI-Konfiguration im bios als Legacy auszuwählen? Eventuell verhindert das die automatische Zuweisung.


    Wenn der PP allerdings abgeschaltet ist, könnte man vielleicht trotzdem einfach, wie Heilbar vorgeschlagen hat, einfach den IRQ einem anderen Gerät zuweisen.

  • - Die AMIBIOS System Configuration-Tabelle listet keinen PP auf und laut dieser ist dem auch kein IRQ zugewiesen worden.
    - Wenn ich von der Win98SE-CD MS-DOS mit CD-ROM-Unterstützung boote und die MSD.EXE (v2.14) von der CD starte, wird LPT Ports... 0 angezeigt und der IRQ 7 ist frei, also kein PP konfiguriert.
    ga-7ixebiossysconfig.jpgga-7ixedoslptdeakt1.jpg


    => Von Seiten des BIOS scheint also alles okay zu sein.


    - Wenn ich MSD unter Win98SE starte, zeigt es mir LPT Ports... 1 an und im Gerätemanager und den Systeminformationen einen konfigurierten PP.
    ga-7ixewinlptakt2.jpgga-7ixewinlptakt1.jpg


    - Wenn ich den PP jetzt im Gerätemanager deaktiviere, zeigt MSD zwar LPT Ports... 0 an, aber in den Systeminformationen wird der IRQ 7 nicht als (frei) gekennzeichnet. Er wird dort nicht einmal angezeigt. Stattdessen springt die Liste von IRQ 6 direkt zu IRQ 8, als ob es die 7 gar nicht geben würde ?(
    ga-7ixewinlptdeakt2.jpgga-7ixewinlptdeakt1.jpg


    - Hier zum Vergleich die Systeminformationen eines GA-6BXC mit im BIOS deaktiviertem PP:
    ga-6bxcwinlptdeakt2.jpg :-Darius oder besser gesagt: SOLLTE


    - Eine Jumperkonfiguration bietet das Board leider nicht.


    - Habe mal in der PCI-Konfiguration des BIOS die DMAs 1+3 sowie die IRQs 5+7 auf Legacy ISA festgelegt und dazu noch PnP OS auf NO gestellt. Leider alles ohne erkennbaren Effekt.


    => Das ganze sieht sehr nach einem Windowsproblem aus. Ich werd jetzt einfach mal die GUS PnP einbauen und schauen, was passiert...

    Ich werde mich von keinem einzzzigen Prozzzessor trennen.
    Jedoch lockt es mich beinahe, ihn Dir zu überlassen, nur um zu sehen, wie er Dich in den Wahnsinn treibt :evil:


    Meine Begehren

    Einmal editiert, zuletzt von Lotosdrache ()

  • Jetzt ist auch die GUS PnP drinnen
    ga-7ixebiossysconfigGUS.jpg


    und wie befürchtet, gibt es Ressourcenkonflikte mit den DMAs und IRQs, solange der PP aktiviert ist
    ga-7ixewinlptaktdma.jpgga-7ixewinlptaktirq.jpg


    Nach der Deaktivierung im Gerätemanager, sieht die Sache wesentlich besser aus als befürchtet. Die GUS PnP kann DMA 1 und IRQ 7 belegen. Damit kann ich erst einmal leben, auch wenn es im Gerätemanager nicht ganz perfekt aussieht.
    ga-7ixewinlptdeaktdma.jpgga-7ixewinlptdeaktirq.jpg
    :D:D:D:D:D:D:D


    Und hier noch der Zwischenstand vom Aufbau
    amd-boy.jpg


    Als Graka dient noch die Radeon 8500. Es fehlen noch der SCSI-Controller DC-2974 PCI Dawicontrol (liegt hier rum), die NIC Allied Telesis AT-2701FTX, das Nakamichi und evtl. ein IDE ZIP-LW und eine PowerVR PCX2 oder Rage II+DVD.


    So, jetzt ist es Zeit für den AGP-Stabilitätstest...


    EDIT
    Hat zufällig jemand die IRQ-Sharing-Tabelle für dieses Board? Das würde mir den Einbau der übrigen PCI-Karten sehr erleichtern!

    Ich werde mich von keinem einzzzigen Prozzzessor trennen.
    Jedoch lockt es mich beinahe, ihn Dir zu überlassen, nur um zu sehen, wie er Dich in den Wahnsinn treibt :evil:


    Meine Begehren

    2 Mal editiert, zuletzt von Lotosdrache ()

  • Wir sind ja hier nicht in einem gewissen anderen Forum wo man nur 1024px Bilder einbinden kann ;) :D

    Compaq Deskpro 286n/12MHz - 1MB - 40MB HDD - 3,5" Floppy //
    Panatek 386DX33 - 80387 - 8MB - 504MB CF2IDE - 5.25" & 3,5" Floppy - SB Vibra - NIC - 512Kb VGA //
    486DX2-66 - 16MB - 4GB CF2IDE - 5,25" & 3,5" 2,88MB Floppy - DVD - SB Vibra - NIC - 1MB CL VLB VGA //
    Intel Pentium 233MMX - 64MB - 16GB CF2IDE - 3,5" Floppy - DVD - SB AWE64 - NIC - 3Dfx Voodoo Banshee//
    Intel Pentium III 600MHz - 256MB - 4GB CF2IDE - 3,5" Floppy - DVD - SB AWE64 - NIC - 3Dfx Voodoo 3 3000 //

  • Mit PCI List 2.22 konnte ich nun die Register auslesen und sehen, daß sowohl auf Seiten des Chipsatzes als auch auf Seiten der Radeon 8500 das SBA aktiviert ist :) Der Final Reality 1.01 Benchmark lief ohne Probleme durch, auch der integrierte AGP-Test :Banana Vermutlich beziehen sich die Infos zum SBA, die im Netz stehen, auf eine ältere BIOS-Version. Ich sehe sie jedenfalls mal als veraltet an.


    Habe auch mal eine ISA Plug'n'Pray Netzwerkkarte von 3Com zusammen mit der GUS PnP eingebaut. Ergebnis: GUS 5+7, ISA NIC 9. Dann noch eine PCI NIC von Realtek und den PCI SCSI-Controller von Dawicontrol dazu:
    AGP 11
    GUS PnP 5+7
    ISA NIC 9
    SCSI 10
    PCI NIC 3
    USB 3


    Nach meinen ganzen Versuchen mit den Karten in verschiedenen Slots, ergibt sich etwa folgendes Schema für das IRQ-Sharing:
    AGP + PCI3
    PCI1 + onboard USB (bevorzugtes Sharing)
    PCI2
    PCI4 + PCI5
    ISA1
    ISA2
    onboard IDE


    Dabei hat der onboard USB Controller seinen IRQ bevorzugt mit dem PCI Slot 1 geteilt, aber sobald die IRQs überbelegt waren, teilte er ihn sich unter Windows 98SE (!) immer mit der PCI Netzwerkkarte, egal ob die nun im PCI Slot 1, 2, 3 oder 4 steckte. Die Vorkonfiguration durch das BIOS wich laut der System Configurationstablle mit zunehmender Belegung immer mehr von der späteren Konfiguration durch Win98SE ab, vermutlich weil das BIOS die ISA PnP-Karten bei der Verteilung nicht berücksichtigt hat.


    Werde meine Karten jetzt so anordnen:
    AGP: ganz klar eine Grafikkarte
    PCI1: (frei)
    PCI2: Dawicontrol DC-2974 SCSI-Controller
    PCI3: (frei)
    PCI4: Allied Telesis AT-2701FTX NIC
    PCI5: (frei)
    ISA1: GUS PnP (hier hat sie mehr Abstand zum Netzteilkabel und die Lüftungslöcher im Boden bleiben auch etwas freier)
    ISA2: (frei)
    So muß keine Karte oder onboard Komponente ihren IRQ teilen :D

    Ich werde mich von keinem einzzzigen Prozzzessor trennen.
    Jedoch lockt es mich beinahe, ihn Dir zu überlassen, nur um zu sehen, wie er Dich in den Wahnsinn treibt :evil:


    Meine Begehren

Jetzt mitmachen!

Sie haben noch kein Benutzerkonto auf unserer Seite? Registrieren Sie sich kostenlos und nehmen Sie an unserer Community teil!