Beiträge von Sigurd4Warp

    Fortschritte heute:


    Über den IBM Bootmanager



    lassen sich sowohl Windows XP



    als auch Windows 7 Pro 64



    separat starten.


    Hatte zunächst XP installiert, das wollte dann die Startdateien aber partout in die erste primäre Partition der ersten Platte, vormals "OS/2 Version 2.11" schreiben. Naja, dann Windows 7 installiert, welches seinen Bootmanager gleich mit reingepackt hat.


    Nachdem ich unter Windows 7 mittels bcdboot auf dem 7er Laufwerk die Startdateien erzeugt hatte, konnte ich das schon mal direkt vom IBM Bootmanager aus auswählen.


    Für XP habe ich dann von der XP Pro CD gebootet, dort mit R in die Reparaturkonsole und dann mit fixmbr c: und fixboot c: dort neue Sektoren geschrieben.


    Dann wieder mit USB DFSEE Stick gebootet, den IBM Bootmanager als Aktive Partition festgelegt, die 2.11 in Windows XP SP3 umbenannt und Voila.


    Klar, hätte auch alles neu machen können, aber so funktioniert erstmal alles wie es soll.


    In den jeweiligen Laufwerksverwaltungen der Windowsinstallationen habe ich die Laufwerksbuchstaben der OS/2 Partitionen entfernt, sodass bei beiden nur die Windows Laufwerke im Explorer angezeigt werden.



    Soweit, so außerordentlich zufrieden.


    Es war etwas Sucharbeit, die Treiber für XP und 7 zu bekommen, aber ASROCK (Mainboard ASROCK 980DE3/U3S3) hat immer noch die USB3 und Chipsatz Treiber für XP und 7 Online, für den Sound unter Windows 7 habe ich den CMedia Vista Treiber genommen. Die X600 läuft unter XP mit Treibern für die "X200,X300,X1050" unter 7 mit dem "normalen Windows 7" Treiber dafür.

    In beiden Gerätemanagern gibt es jedenfalls keine Ausrufe- oder Fragezeichen mehr.


    Im nächsten Schritt sind nun die OS/2 Installationen dran.

    Spannend.

    Kann man OS/2 denn heute fürs Surfen einsetzen oder gar mehr einsetzen?

    Kann das OS/2 denn noch DOS Programme ausführen?

    Ja, auch auf UEFI und GPT kann ArcaOS ab 5.1. DOS und Windows 3.11 Programme, wie von OS/2 seit jeher gewohnt, ausführen.


    Und Nein, mit OS/2 (ArcaOS) kann man zwar vieles machen, aber ich kann nur dringend abraten egal welche Version davon als Produktivsystem zu nutzen.

    Zudem kommen seit der 7. Generation der Intel core i Prozessoren massive Probleme mit der Nutzung des verfügbaren Arbeitsspeichers (als 32-bit System ohnehin mx. 4 GB, auf aktueller Hardware meist max 1,5 GB) dazu. Viele Sachen gehen natürlich noch gut, Textverarbeitung usw., aber alles was mit Online zu tun hat, kann man ohnehin vergessen.

    Ein spannendes Experiment :D Bin auf mehrere Ergebnisse gespannt:

    a) Bis zu welcher OS/2-Version herunter wird die Hardware supportet?

    b) Funktioniert die CPU wirklich als SMP-System im klassischen Sinne?

    c) Ist die Platte wirklich bis in die hinterletzte Partition bootbar?

    d) …

    Hi,


    es wird noch etwas dauern, bis ich richtig verwertbare Ergebnisse habe, aber hier schon einmal:


    zu a.) die OS/2 2.0 Version könnte theoretisch auch noch gehen, davor eher nicht


    zu b.) Ja, die SMP Unterstützung von OS/2 existiert seit der Version 2.11, ich habe aktuell auf einem Ryzen 7 PRO 7840U (Thinkpad Z13 Gen 2) 16 Kerne. Angeblich soll die SMP Unterstützung bis zu 256 Kerne unterstützen


    Siehe Bild:



    zu c.) Nein, das wird nicht gehen, da OS/2 nur von den ersten 1024 Zylinder der Platte booten kann. Von daher muss ich sehen, wie viele sich dann nun wirklich starten lassen.


    EDIT: Das Problem hat übrigens die ArcaOS Version ab 5.1 nicht mehr, da diese mit UEFI und GPT umgehen kann.

    Ja, wenn man so lange (seit 1995) mit OS/2 zu Gange ist, dann will man mal alle - bzw. so viele wie möglich - nativ auf einem Rechner haben. Zumindest theoretisch müsste das mit den hier im Bild bereits als Partitionen mit DFSEE angelegten Systemen. Die Systeme selbst sind noch nicht auf dem speziell für OS/2 optimierten PC installiert. Das kommt nach und nach. Ich habe schon viele Multiboot Systeme gehabt und installiert, so viele aber noch nicht parallel. Mal schauen.


    Auf einer zweiten SSD sollen dann noch Windows XP und Windows 7 Pro 64 landen, die auch über diesen hier dargestellten Bootmanager zu laden wären.


    Eine dritte 2 TB HDD wird dann dazu das Datengrab.


    Wenn das klappt, kann ich einige meiner Retro Rechner - bis auf ein schönes reines DOS System - wohl einmotten oder verkaufen.


    Da die Hardware Daten aus 2005 bis 2011 hat (die SSDs sind noch neuer) nur eine kurze Aufzählung hier. Es geht eher um OS/2.


    AMD Opteron 3320EE (nur 25 Watt)

    Wasserkühlung (absolut geräuschloses System)

    Ati Radeon X600 PCie (gibt es SNAP Grafikkartentreiber für OS/2 für)

    Cmedia 8738 Soundkarte (gibt es 4.1 OS/2 Treiber für)

    1 TB SSD (OS/2)

    512 GB SSD (Windows)

    2 TB HDD


    Ergänzung:


    OS/2 Version 2.11, Warp Server 4, Warp Server for eBusiness, eComsation und ArcaOS sollen SMP Versionen sein.


    Ergänzung II:


    In die rechte, freie Ecke des Midi Tower wird noch etwas passendes eingesetzt! ;)



    Letzte Woche angekommen. Hatte ich vor über 20 Jahren schon einmal. Beides OVP (Board mit Kabeln, Handbuch, CD; CPU mit Lüfter und Sticker etc.) und unbenutzt. Ein passendes I/O Slotblech habe ich mir ebenfalls schon besorgt. Daraus wird der XP Teil in einem großen Retroprojekt, das mich vermutlich auf Jahre beschäftigen wird.


    Das Board hatte mir seinerzeit gute Dienste geleistet, es hatte für mich etwas besonderes, weil es nicht viele mit diesem Chipsatz gab und da North- und Southbridge in einem Chip sitzen. Überlege gerade, ob das hier noch Retro ist, aber XP war noch nicht draußen, als es das Board schon gab. Naja, andernfalls sehe man es mir bitte nach.


    ich mache Dir den Scan sehr gerne heute Nachmittag.

    Zwecks Skalierung, welches Maß hat der Bogen?

    Der Bogen hat das Maß: (genau) 17cm hoch, (genau) 12 cm breit.


    Ich habe eine PNG Datei mit 68 Megabyte und eine JPG Datei mit 8,4 Megabyte.


    Wie kommt die PNG am besten zu Dir?


    Die 8 MB JPG kann ich ja hier anhängen. Ist das so in Ordnung für Dich?

    Eine tolle Zeitkapsel, Glückwunsch :)


    Erkennt man die OS/2-Fähigkeit des Treiberpaketes daran, dass Tools dabei sind, die eigentlich bei Windows 3.1 inbegriffen wären? Oder bedeutet das eher, dass die Treiber auch unter Win 3.0 gehen, das von Haus aus keinen Wave-/MIDI-Payer hat?


    PS: Hoffentlich macht jemand eine Repro von dem Stickerbogen :D

    Vielen Dank. Den Stickerbogen scanne ich heute Nachmittag ein und sende ihn an Dana.


    Ja, mit den OS/2 Soundtreibern ist das so eine Sache. Weil der Protected Mode für DOS und WINOS2 in OS/2 aus nachvollziehbaren Gründen (OS/2 lässt keine direkten Speicherzugriffe aus VDMs zu, damit diese nicht das ganze System in den Abgrund reißen - was freilich dennoch mal passieren kann :D ) die Installation von "nativen" DOS oder Windows 3.1 Soundtreibern in der Regel verhindert, helfen hier spezielle Soundtreiber weiter. Da taten sich die von Terratec besonders hervor.


    Hier mal ein paar Bilder zur Installation der 16/96 Treiber - ESS 1868 Chip - Terratec Gold unter OS/2 Warp 4, die veranschaulichen das am besten:



    Führt dann in der config.sys dazu:



    Wirklich ein guter Sound unter OS/2.

    Es ist schon etwas her, dass ein spezielles Spezialpaket in meine Hände gelangt ist. Hintergrund der Anschaffung seinerzeit war eigentlich OS/2 Warp Version 4, und zwar die Funktionen Voice Type und Voice Navigation. Dafür braucht es eine möglichst gut von OS/2 unterstütze Soundkarte und ein entsprechendes Headset, zu teuer sollte es aber nicht sein.


    Eine Auktion mit einem Bundle Angebot erregte meine Aufmerksamkeit. So sah das aus:



    Wie Sie sehen, Sie sehen Nichts.


    Der geöffnete Karton macht es etwas leichter:



    Eine perfekte Kombination!!


    Eine Terratec 16/96 und dazu noch Boxen und ein Headseat!


    Das tolle an der 16/96 ist in diesem Fall, dass diese auch nicht nur für OS/2 sondern auch für WINOS2 MIDI Unterstützung mitbringt, Terratec stellt dafür sehr gute Treiber zur Verfügung!


    Und das ganze für nur 222 Mark! Ich weiß nicht mehr, was ich bei der Auktion bezahlt habe, ich glaube es waren 79 Euro.


    Verteilt man mal den ganzen Inhalt des Pakets, so gibt es doch einiges zu sehen:



    Neben der Hardware sind auch 3 Disketten und eine Version von Smart Word Original für Windows dabei, wohl auch eine Sprachsoftware.


    Die Aufkleber sind auch noch tadellos und ganz witzig.



    Die Disketten mit Treibern/Programmen für DOS, Windows 3.1 und Windows 95 weisen diese auch für eine "Maestro 16/96" passend aus.



    Hier die kleinen, aber feinen Lautsprecher:



    Und hier die genaue Bezeichnung des Headset:



    Leider zerfielen die Ohrmuschelschoner bei der ersten Berührung buchstäblich zu Staub, und die Halterung des Mikrofons brach beim ersten Justierversuch direkt auf. Der Kunststoff hatte wohl über die lange Zeit schon einiges in die Umgebung abgegeben. Ansonsten aber alles Tippi Topi.


    Meine Versuche, die Karte unter OS/2 ans Laufen zu bringen, mit den 16/96 Treibern für OS/2 von Terratec, scheiterten gnadenlos.


    Da meine Lernkurve nicht besonders steil war, dauerte es etwas, bis ich die Ursache herausfand.


    Jedenfalls ist die Soundkarte hier nun für den NexGen PC vorgesehen, hier kann ich es auch gleich demonstrieren.


    So schön sitzt die Karte im Board.



    Aufmerksamen Betrachtern fällt es sicher sofort auf, bei mir fiel der Groschen mal wieder nur Pfennigweise.


    Naja, jedenfalls ist ja Windows für Workgroups bereits auf der HDD dieses Roh PC installiert.


    Die Treiber und Programmdisketten, die ich zuvor erstmal gesichert hatte, funktionieren tadellos! Ein Hoch und Lob auf und an Terratec, von deren Seite man immer noch all diese Treiber laden kann!!



    Ein CD Laufwerk habe ich nicht daran angeschlossen, deshalb war das egal. Und schwupps, war die Installation der Treiber beendet.



    Unter Windows entstand eine entsprechende Programmgruppe, die sich durch die "Programmdiskette" noch weiter auffüllte.



    Ganz schön viel, von so einer kleinen Diskette!



    Das Media Rack geöffnet, macht schon was her:



    Wenn doch hier alles so reibungslos lief, warum, verflixt nochmal, scheitern alles OS/2 Bemühungen?


    Ja, schauen wir noch einmal genau auf die Karte:



    Und was erkennen wir da Unten Rechts: Es handelt sich um eine Maestro 16/95, nicht 16/96!!


    Nachdem ich das herausgefunden hatte, nichtsdestoweniger zunächst nicht glauben wollte, ergab es trotzdem einen Sinn.


    Die 16/95 hat einen Opti 82C924 Chipsatz.


    Der OS/2 Treiber, den ich für die 16/96 geladen hatte, war aber für den ESS1868 der 16/96!! Die beiliegenden Treiberdisketten waren zwar mit 16/96 bedruckt, enthielten aber auch den Opti Treiber. Vielleicht gab oder gibt es eine 16/96 auch mit Opti Chipsatz, ich habe da nicht weiter recherchiert.


    Kein Wunder also!


    Als 16/96 fand ich eine Terratec Gold, die ich mir dann auch für OS/2 zugelegt habe.


    Hier mal die beiden Karten im Vergleich:



    So, nun kommt also diese Geschichte ("wieder mal eine von Vater aus dem Paulanergarten" - wie meine Söhne zu sagen pflegen) zu Ende.


    Warum es eine Terratec 16/95 ist die dem Paket beilag, obwohl alles andere von einer 16/96 spricht, ist mir schleierhaft, macht ja auch letztlich nichts. Hauptsache alles funktioniert.


    Ich wünsche einen schönen, entspannten Abend!

    Ja, Gestern habe ich noch in dem Gehäuse Thread geschrieben, dass ich nur wenig Zeit für dieses Hobby habe, aber irgendwie hat mich das motiviert, mich nun doch einmal wenigstens diesen einen Abend an das Werk zu setzen.


    Nun war es etwas ungünstig, dass ich kein "Loses" Diskettenlaufwerk zur Hand hatte, um die bisher nicht genutzte Festplatte zu formatieren und mit MS DOS 6.22 zu bespielen. Abhilfe erfolgte durch den Einbau in einen anderen PC. Dort habe ich dann auch gleich alle notwendigen Treiber mit auf die Platte kopiert.


    Zum System selbst:


    - NexGen Nx 586 P 90 Mainboard

    - Spea V7 Mirage VL Grafikkarte 1 MB

    - VLB Schnittstellencontroller

    - Terratec 16/95 (!, nicht 16/96!) ISA Soundkarte

    - 1.6 GB IDE HDD



    Die Fortschritte am Abend waren:


    - HDD formatiert

    - mit MS DOS Startdiskette inkl. CD ROM Treiber gestartet, MS DOS 6.22 von CD installiert, command.com musste nachträglich manuell kopiert werden, hatte ich wohl damals nicht mit auf CD gebrannt.

    - Windows 3.11 von CD installiert

    - Dr. Hardware installiert

    - Spea V7 Mirage Treiber installiert



    Nicht geklappt hat:


    - Installation des Soundkartentreibers von HDD; möchte unbedingt nur von Diskette; wird dann nachgeholt.


    Jetzt sammle ich mir erstmal die fehlende Hardware zusammen, aber es ist doch sehr erfreulich, dass das System sehr gut funktioniert, auch dass die BIOS Batterien seit dem letzten Mal weiterhin klaglos ihren Dienst versehen und die Festplatte vom BIOS ohne Probleme erkannt wird.


    Hier mal ein paar Bilder, wenn ich dann Zeit habe, werde ich meinen Youtube Kanal mal mit bewegten Bildern bestücken.