IBM PC AT (5170) Mainboard Reparatur

  • Habe über @struuunz unter Anderem ein schönes IBM PC AT (5170) Mainboard aus einem Schrottpaket bekommen.


    IMG_20191206_081614.jpgIMG_20191206_082741.jpg


    Leider sah es auch dementsprechend aus:


    IMG_20191206_081637.jpgIMG_20191206_082656.jpgIMG_20191206_082725.jpgIMG_20191206_082720.jpgIMG_20191206_082729.jpgIMG_20191206_110515.jpg


    Es gab einige Kratzer, Blessuren und eine Region, wo ein Akku/ Batterie gesaut hat. Ein RAm Chip fehlte, der zweite fehlende fand sich im Karton ganz unten wieder...


    Als erstes die ganzen Bahnen kontrollieren, die betroffen sind. Allerdings habe ich keine einzige Unterbrechung gefunden. Die essig-Kur kam noch davor. Die eine Stelle auf dem ersten Bild oben drüber hat gut geblubbert.


    Nun gut, also eine RAM Bank bestückt und POWER ON. Doch leider zeigte die POST Karte nur "00 dd" und "dd 00" im Wechsel an. Kein piep, kein Bild... Aber zumindest lebt es ein wenig. Es besteht also Hoffnung.
    IMG_20191206_101807.jpg



    Erster Verdacht: BIOS Chips leer. Leider kann der Programmer die TMM23256 Chips nicht lesen, also geschwind neue gebrannt, das Image gibt es ja im Netz, doch keine Änderung...


    Der eine 74ALS244 sah ziemlich angefressen aus. Also raus mit dem:
    IMG_20191206_111112.jpg



    Aber er lebt:


    IMG_20191206_111116.jpg



    Also wieder rein inklusive Sockel und weiter messen und schauen. Ich hatte RAM Bausteine in Verdacht. Wenn ich Bit 0 gezogen habe, zeigte die POST Karte statt 00 die 01. Also sollte doch dieser Chip funktionieren. Bei Bit 1 zigte sie 02. Bit 3 die 04, dann die 08, dann die 10, dann die 20, dann die 40, dann die 80. Beim Parity Chip war wieder 00 dd zu lesen. Bit 8 fing dann wieder mit 01 an bis bit 15, die 80. Auch hier war es nur der Parity Chip, der keine Änderung bewirkte, ob er steckte oder nicht.


    Also den einmal getauscht,doch nix.


    Beim Nachmessen mit dem Oszi fiehl mir auf, dass der Ausgang vom Parity Chip oft in der "Luft" hängt. Dann gemessen: ja, dieses Beinchen hat keinen Kontakt zum Board, bzw. der Sockel. Auch das Beinchen daneben nicht. Also raus damit!


    IMG_20191206_115550.jpg



    Und neuen Sockel rein:


    IMG_20191206_121020.jpg



    Sieht man kaum den unterschied.



    Jetzt kam ein neuer Code:


    IMG_20191206_121334.jpg



    Doch im Heft ist dieser nichtssagend. Auch wieder kein Piep, kein Bild...


    Also weiter suchen. Und tatsächlich, noch eine Unterbrechung:


    IMG_20191206_121442.jpg



    Aber es ist nur die Leitung zum Keylock...



    Auf der Unterseite dann aber doch noch was: 2 Kurzschlusse! Da haben sich die Pins der RAM Sockel zum Teil so stark verbogen, dass diese auf der Platine auflagen. Und 2 davon haben den Schutzlack durchdrungen und haben sich mit Leiterbahnen kurzgeschlossen...



    Diese behoben und:


    IMG_20191206_120911.jpg



    FIRST LIGHT!!!!!!



    IMG_20191206_122242.jpgIMG_20191206_122248.jpgIMG_20191206_134448.jpg



    256k gefunden und gut, BASIC lädt, wenn man F1 drückt und er nichts sonst zum booten findet.



    Nun suche ich also mindestens einen der 41128 RAM Chips (staked RAM) und diese 128k Speichererweiterungskarte, um von 512k auf 640k zu kommen.



    Ein sau geiles Board mit 6MHz 80286er :)


    Laut @matze79 könnte auch ein 386SX in dieser Bauform drauf laufen. Also falls einer einen hat, nur her damit. Win95A mit 6MHz 386SX macht bestimmt viel Spaß, wenn ich den RAM auf 4MB bekomme...

  • @Beckenrand-schwimmer


    Lob und Anerkennung! Und schön bebildert - wie meine Sachen :D


    Ich hab ja auch den 5170 mit PGA 286 6 MHz, ... leider habe ich keinen PGA 386SX ... wäre zu geil wenn der auf dem Brett laufen würde.


    Gruß

    :freak RetroComputerPoPe - Dr. (Ehrenhalber) Darius von Bernstein - Grünstein - Lötstein :freak


    * Bezwinger der EIZO ( ͡° ͜ʖ ͡° ) *


    Päpstlicher DOSianer mit mittlerweile jeder DOS-Architektur (XT/286/386/486/586/686...)
    Status: Don't mess with the RetroPoPe / Erweiterter Amateur mit der unoffiziellen Bräter-Lizenz *g*

  • Sehr schön, dass du das wieder hinbekommen hast – Respekt!


    Das mit dem PGA 386SX klingt interessant. Ich habe einen IBM 5162 mit einen Harris 80286-25 und 20 MHz X-tal aufgerüstet. Damit läuft er zumindest auf 10 Mhz, mehr scheint nicht möglich zu sein da noch andere Komponenten das System limitieren.
    Könnte man auch den 5162 mit einen 386er upgraden, bzw. was gibt es zu beachten?

  • Geht leider nicht ich habs gecheckt.


    Die PGA 386SX CPU hat zwar die selben Signale, aber mehr Pins.
    Man braucht also trotzdem einen Interposer wie beim 286 zu 386SX/486 Upgrade für TQFPs

    Damn It. ||

    :freak RetroComputerPoPe - Dr. (Ehrenhalber) Darius von Bernstein - Grünstein - Lötstein :freak


    * Bezwinger der EIZO ( ͡° ͜ʖ ͡° ) *


    Päpstlicher DOSianer mit mittlerweile jeder DOS-Architektur (XT/286/386/486/586/686...)
    Status: Don't mess with the RetroPoPe / Erweiterter Amateur mit der unoffiziellen Bräter-Lizenz *g*

  • Dank Struuunz habe ich 2 Ersatzkäfer bekommen. Nun hat das Board 512k RAM. Sehr genial!
    Auch die Fehlermeldung ist Klasse. Da kann man den betroffenen Käfer direkt erkennen.


    Es ist ja ein 80287 gesteckt. 4MHz FPU Power!
    Und 1,7 FPS im 3D Bench.


    NSSI bricht mit einem Fatal Error ab..

Jetzt mitmachen!

Sie haben noch kein Benutzerkonto auf unserer Seite? Registrieren Sie sich kostenlos und nehmen Sie an unserer Community teil!